·   · 1 posts
  •  · 4 friends
  •  · 4 followers

Somethings wrong

Here is a couple of pictures of the leaves on my PPP growing in DWC, it seems as the bad leaves started towards the top, but not right at the top and now it’s kinda all over the tips are brown pointing down and the edges are yellow. I tried growing with just plain water for a week didn’t seem to help I’ve been trying a foliar spray with low-dose of Cal Mag. Help please.
0 0 0 0 0 0
  • Set badges
  • 334
Comments (7)
    • You need to tell us a bit more about your grow, starting with the PH of your water, that's the # 1 culprit in hydro, light burn is pretty common with the new LED's these days too. 

      Foliar feeding that far along in flower is a good way to jump start bud rot

      0 0 0 0 0 0
      • Another ask and run I guess

        0 0 0 0 0 0
        • Nobody running here, I don’t think it’s light burn because the leaves at the bottom that aren’t getting much light has the same yellow edges. It’s really got me puzzled because I got three plants in Coco that they all started at the same time and they’re doing fine with this one plant in DWC is having a rough go about it. Thanks for your help. CPW.

          0 0 0 0 0 0
          • So what are you feeding it and what is the PH

            0 0 0 0 0 0
            • Thanks in advance, i’m feeding the the bloom cording to the package of a later day plant also given that Cal Meg, which equals to about 2200 ppm with purified water, pH is 5.8-6.2. These off color leaves are only on my one DWC the three other plants started exact same day in Coco look very good.

              0 0 0 0 0 0
              Not logged in users can't 'Comments Post'.
              Info
              Category:
              Created:
              Updated: